Upload Image to Firebase Storage

I tried to upload an image to the Datastorage in different ways but i didnt get it…

If Button is pressed > Target “Project” > Action “Upload file to Storage” > Filename and Path reffers to an image properties “fullpath” and “filename”

I also tried to set the “Action > Property > Project > Firebase > Storage Url” 10ms before i call the Upload Part. Nothing happends.

The Permission in Storage is:
service firebase.storage {
match /b/{bucket}/o {
match /{allPaths=**} {
allow read, write;

I used this Url Syntax:
Its an US-Region because the EU Server-Urls are not working with Firebase Real Time Database imports for any reasons… So i tried it with US Region

What did i miss?
Thank you!

We found a bug on Android when uploading an asset file (a file that you add to the application in the editor). This is fixed now.

Uploading the picked file works fine (file added by the user in the application).

Here’s a test project for uploading files to Firebase Storage firebase_storage_test.pma (92.3 KB)


Works perfect, thank you!

“Filename” is the “source File” and “path” is the path to the Storage (not the full URL!) like “/images/myNewImage”. Its important to setup the firebase files in the “Edit configuration” menu first.

How is it possible to download the File from Firebase?
Currently i did it like that and it works:

  1. Action
    “Page 1” - “Enter” > “Project” - “Download Url” > “https://firebasestorage.googleapis.com/.../?alt=media” (0 Delay)
  2. Action
    “Project” - “Download finished” > “Image 1” - “Set Image” > “Project” - “Downloaded File” (0 Delay)

But its a bit difficult if i got multiple files in my app because the index of “Downloaded Files” changes every time i put a new download in Queue.

Is there any better solution?

Tank you!

There is no need to download the file. The image widget does all the work.


Oh my god…
I tried to do that but if i upload a Image and call it like you describe, than upload an image with exactly same name and path and call it again it doesnt work.

The solution cost me a day hahaha: Project > Clear Cache!

Now it works fine. Thank you!

Back to Flipabit >
Copyright © 2018. Flipabit Team. All rights reserved.